[slime-devel] SLIME and OpenMCL 0.14.1: debugger question

Constantine Vetoshev gepardcv at yahoo.com
Mon Feb 16 15:37:30 UTC 2004

Greetings all,

I'm giving SLIME a spin, and I fetched a FAIRLY-STABLE version
from CVS yesterday. M-x slime worked fine, and I had a REPL
buffer. Unfortunately, whenever I drop into the OpenMCL debugger
and choose a restart (like ABORT or ABORT-BREAK), all further
attempts to interact with the REPL result in a "Lisp is not ready
for requests from the REPL" message, and I have to restart
SLIME. ABORT-BREAK actually gave me a CL-USER prompt, but with
the same error message.

Do I simply misunderstand what's going on? Is this an OpenMCL
issue? Some kind of threading issue? I tried searching on gmane
for this error, but it looks like people generally run into it
when trying to do several things at once. I just
evaluated (error "test error") on the Lisp prompt; I expect to
just enter the debugger and choose a restart.

Many thanks,

More information about the slime-devel mailing list