[lispbox-devel] libgio-2.0.so.0

Andreas Eriksen andreer at pvv.ntnu.no
Wed Feb 29 21:47:57 UTC 2012

The current version of lispbox depends on libgio, which is part of glib2. Unfortunately, the version of glib2 in CentOS 5.5 is too old and doesn't contain libgio. If you are determined to use lispbox on CentOS, you will probably have to track down an unofficial updated glib package, or download and compile it yourself.

This is only based on what I found with a few random web searches - I don't access to a machine running CentOS 5.5 so I haven't tried it myself.

I hope to solve such problems in the next release of lispbox by statically linking all required libraries, but because my time is currently very limited I'm waiting for emacs 24 to be released first. Hopefully this should be very soon.


On 2/29/12 8:15, Codefor wrote:
> I run lispbox on CentOS 5.5
> got
> /home/yugaohe/lispbox-0.7/emacs-23.2/bin/emacs: error while loading shared libraries: libgio-2.0.so.0: cannot open shared object file: No such file or directory
> why is that?
> --
> *Codefor*
> Softeware College,Beihang University,BJ,PRC.
> Nickname:Codefor
>              ------Just enjoy your life before it melts like an ice cream!
> _______________________________________________
> lispbox-devel mailing list
> lispbox-devel at common-lisp.net
> http://lists.common-lisp.net/cgi-bin/mailman/listinfo/lispbox-devel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/lispbox-devel/attachments/20120229/3df462c1/attachment.html>

More information about the lispbox-devel mailing list