Where to go with EQL5 and QT specific questions?

Erik Winkels aerique at xs4all.nl
Thu Apr 29 14:31:53 UTC 2021


> On 29-04-2021 13:50 Renaud Casenave-Péré <renaud at casenave-pere.fr> wrote:
> Actually I was referring to an earlier release. The currently released packages
> are considered fully working. Paul’s solution is the way to go.
> Could you try with Paul’s solution and report back if it works for you or not?

I had tried Paul's solution but it didn't work for me.  Now that you said it should actually work I tried again and I did also see where I did go wrong on my earlier attempt.

So, after adding Drakma as dependency to Renaud's `eql5-sfos` I ran into the issue I mailed about earlier.  After trying Paul's solution by adding this to the `eql5-sfos.pro` file:

- `LIBS += -L/usr/lib/ecl-21.2.1 -l:libasdf.a -l:libsockets.a`

And doing this in `src/eql5-sfos.cc`:

- `ecl_init_module (NULL, init_lib_ASDF);`
- `ecl_init_module (NULL, init_lib_SOCKETS);`

It gets me past the `SB-BSD-SOCKETS` and `UIOP/OS` errors, but now I get the following error:

    $ eql5-sfos 
    [D] unknown:0 - Using Wayland-EGL
    Condition of type: FILE-ERROR
    Filesystem error with pathname "SYS:help.doc".
     1) the file does not exist, or
     2) we are not allowed to access the file, or
     3) the pathname points to a broken symbolic link.
    No restarts available.
    Top level in: #<process TOP-LEVEL 0xb0581fc0>.

Which is at least different :-)

I tried including `help.doc` as a dist file in `eql5-sfos.pro` but that didn't work and I guess there's more to solving it than that.  (Perhaps something to do with `libecl-help.a`?)

Thanks so far,

More information about the ecl-devel mailing list