Compiled program complaints on absent UIOP/OS and UIOP/PATHNAME

Pascal J. Bourguignon pjb at
Sat Apr 2 23:46:58 UTC 2016

Alexander Artemenko
<svetlyak.40wt at> writes:

> Hi!
> I have created a command line program:
> I've tried to build it with sbcl and it worked fine.
> But when I compiled it with ECL, I found
> that right after running, it outputs following error:
> Condition of type: SIMPLE-ERROR
> The packages
> package>))
> were referenced in compiled file
> but have not been created
> Available restarts:
> 1. (IGNORE) Ignore the error, and try the operation again
> Top level in: #<process TOP-LEVEL>.
> Tried ECL 16.1.4 on Ubuntu and ECL 16.0.0 on OSX.
> What is the reason of this error, and how to fix it?

We cannot reproduce your problem because you didn't pass the -norc
option to ecl, or --no-userinit to sbcl.

Also, lisp/setup.lisp is missing:

$ ./build.ecl
An error occurred during initialization:
Filesystem error with pathname #P"/tmp/cl-jslog/lisp/setup.lisp".
 1) the file does not exist, or
 2) we are not allowed to access the file, or
 3) the pathname points to a broken symbolic link..

__Pascal Bourguignon__       
“The factory of the future will have only two employees, a man and a
dog. The man will be there to feed the dog. The dog will be there to
keep the man from touching the equipment.” -- Carl Bass CEO Autodesk

More information about the ecl-devel mailing list