[Ecls-list] Re: building executable using cxml

Rujia Liu 2575127 at qq.com
Mon Jun 29 15:24:20 UTC 2015

Dear all,

I've solved the problem. It failed because asdf:find-system doesn't work in the executable. The only part that used asdf:find-system is locating catalog.dtd, so I modified the code a bit so that it loads catalog.dtd from current directory and it worked.

However, another error occurred when loading Plexippus XPath. I can't remember the exact error message but it's not something like *** not found and looks like non-trivial to fix (I searched for the message and found a macro that is used a lot in the code), so ... is there any good alternatives to Plexippus XPath?

BTW: The error only occured in the executable (under Windows). The whole project works well in interpretation mode with asdf:load-system.

It's the last missing piece to the puzzle. I've already tested the executable with all xpath related codes commented out and it worked. Since xpath is not heavily used, it's ok to replace it with another library.

Thanks in advance!

- Rujia

------------------ 原始邮件 ------------------
发件人: "Rujia Liu";<2575127 at qq.com>;
发送时间: 2015年6月29日(星期一) 晚上6:44
收件人: "ecls-list"<ecls-list at lists.sourceforge.net>; 

主题: [Ecls-list] building executable using cxml

Dear all,

Has any one successfully built an executable with code using cxml? my program starts with a MISSING-COMPONENT error saying that cxml is not found. I looked at the generated libs, there are only four: cxml-xml cxml-dom and so on, but no cxml.lib is found. 

In cxml.asd I can see cxml is a dummy system with no real component but depends on its four modules. Is it the reason that cxml.lib is skipped?

- Rujia

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/ecl-devel/attachments/20150629/5efa11d2/attachment.html>

More information about the ecl-devel mailing list