[Ecls-list] ecl on windows crashes while compiling

Renaud Casenave-Péré renaud at casenave-pere.fr
Wed Aug 28 08:00:10 UTC 2013

On Wed, Aug 28 2013, Renaud Casenave-Péré wrote:

> Hi,
> I tried to compile ecl on Windows7 64bit using Visual Studio 2010 and MinGW32
> but it always crashes when executing the `./ecl_min.exe compile` command.
> The compile process itself seems to work until ecl_min is executed. Here are the
> last lines of MinGW32 console output:
> if [ -f CROSS-COMPILER ]; then \
>                 ./CROSS-COMPILER compile; \
>         else \
>                 ECLDIR=`pwd`/ ./ecl_min.exe compile; \
>         fi
> make[1]: *** [bin/ecl.exe] Error 253
> make[1]: Leaving directory `/c/Users/raz/work/ecl/build'
> make: *** [all] Error 2
> ./ecl_min.exe itself always crashes when I try to execute it myself.
> Did I overlooked something?
> Thanks,

Sorry, I am replying to myself but I should have told you at least the version I
tried to compile.

I cloned the git repository and tried to compile the master branch (last commit
from 3 july) and also tried from the 13.5.1 tag commit.

I didn't touch any options in the Makefiles or with ./configure so I guess I am
compiling a 32bit binary.
I also installed MinGW version of libgmp.

If you need any other information, please ask.

Renaud Casenave-Péré

More information about the ecl-devel mailing list