[Ecls-list] asdf:make-build fails with "In COMPILE-FILE-PATHNAME, the type LIB is unsupported."

Alyssa Carter trillionalyssa at gmail.com
Wed Sep 19 23:35:15 UTC 2012

I'm on Windows 7 and I managed to compile ECL with MSVC. It works fine as a
repl, but it seems that attempting to use asdf:make-build to build any
system fails with the error in the subject. This behavior seems independent
of both the :type argument passed to make-build and of the system you're
attempting to build (I've tried it with a dummy system that contains no
files or dependencies).

After a bit of testing, I think I've determined that the error occurs in
asdf:operate, but my SLIME doesn't know where to find that function's
source, so I'm at a loss for how to continue.

The following code reliably reproduces the error on my machine:
(asdf:defsystem :hands) ; note that the same error occurs if you substitute
:cffi, :lispbuilder-sdl, or any other system
(asdf:make-build :hands)
(asdf:make-build :hands :type :fasl)
(asdf:make-build :hands :type :dll)

; asdf:operate also gives the error
(asdf:operate 'asdf::fasl-op :hands)
(asdf:operate 'asdf::monolithic-fasl-op :hands)
(asdf:operate 'asdf::dll-op :hands)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/ecl-devel/attachments/20120919/5481201a/attachment.html>

More information about the ecl-devel mailing list