[Ecls-list] anyone able to build ecl (stable/git) on mingw ?

bob bobatnet at gmail.com
Sat Aug 25 18:14:54 UTC 2012

On Sat, Aug 25, 2012 at 3:58 AM, Juan Jose Garcia-Ripoll <
juanjose.garciaripoll at gmail.com> wrote:

> On Fri, Aug 17, 2012 at 2:21 PM, bob <bobatnet at gmail.com> wrote:
>> I am trying to build ecl (both stable from git) on MinGW (latest stable)
>> with gcc 4.7.0. But I am presented with different errors during the make
>> stage. Using the stable release (12.7.1) I hit upon make error while
>> building libsocket. So I tried configure with --with-tcp=no. But then I
>> have error in /src/c/file.d.
> I reckon from your private email that you were configuring with a C++
> compiler. That uncovered certain problems with some windows function
> prototypes and the gcc compiler being less permissive about pointer
> coercion. I fixed all problems in the sockets library and find no further
> problems in file.d. So the message is that now ECL seems to build fine in
> Mingw + C++
> I git pull'ed the latest ECL but these configure flags didn't work:
--with-sse=yes --with-cxx=yes. It had problems compiling libffi. So I tried
to compile without dffi with this:

./configure --prefix=/c/lisp/ecl-gcc --with-cxx=yes --with-sse=yes

and it worked! Thanks!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/ecl-devel/attachments/20120825/19c173f3/attachment.html>

More information about the ecl-devel mailing list