[Ecls-list] ECL on iPhone?

Ram Krishnan kriyative at gmail.com
Sun Dec 13 01:23:14 UTC 2009

Elliott Slaughter wrote:
> On Sat, Dec 12, 2009 at 9:01 AM, Ram Krishnan <kriyative at gmail.com 
> <mailto:kriyative at gmail.com>> wrote:
>     Hi Elliott,
>     I started with Red Daly's work (which you referenced), cleaned up
>     a few dependencies, and got ECL running in both the simulator and
>     device. You can checkout a copy from github:
>     http://github.com/kriyative/ecl-iphone-builder
>     It's based on ecl-9.8.4, and requires a newer Boehm-GC (gc-7.2alpha2).
>     I still have some changes to the UIKit ffi code, which I've not
>     checked in yet (mostly to do with Autorelease pools etc.). Other
>     than that you should be able to build, and connect to ECL via
>     SLIME. Let me know if you run into any issues.
> I cloned your repo and tried the instructions in the README, but the 
> build still failed. For a while it looked like it was doing something, 
> and it even loaded ECL and started compiling something, but after a 
> while it ended with the following:
> ./configure 
> --prefix=/Users/elliott/Programming/Lisp/ecl-iphone-builder/iphone/device 
> --host=arm-apple-darwin --target=arm-apple-darwin --disable-c99complex 
> --disable-longdouble --disable-soname --disable-unicode 
> --disable-shared --enable-threads --with-asdf=no 
> --with-bytecmp=builtin --with-cmp=no --with-clx=no --with-defsystem=no 
> --with-fpe=yes --with-profile=no --with-rt=no 
> --with-serve-event=builtin --with-tcp=builtin --with-x=no
> Switching to directory `build' to continue configuration.
> configure: WARNING: If you wanted to set the --build type, don't use 
> --host.
>     If a cross compiler is detected then cross compile mode will be used.
> checking build system type... pentium3-apple-darwin9.8.0
> checking host system type... arm-apple-darwin
> checking for arm-apple-darwin-gcc... 
> /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/gcc-4.2
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... yes
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether 
> /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/gcc-4.2 
> accepts -g... yes
> checking for 
> /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/gcc-4.2 
> option to accept ISO C89... none needed
> checking for arm-apple-darwin-g++... no
> checking for arm-apple-darwin-c++... no
> checking for arm-apple-darwin-gpp... no
> checking for arm-apple-darwin-aCC... no
> checking for arm-apple-darwin-CC... no
> checking for arm-apple-darwin-cxx... no
> checking for arm-apple-darwin-cc++... no
> checking for arm-apple-darwin-cl.exe... no
> checking for arm-apple-darwin-FCC... no
> checking for arm-apple-darwin-KCC... no
> checking for arm-apple-darwin-RCC... no
> checking for arm-apple-darwin-xlC_r... no
> checking for arm-apple-darwin-xlC... no
> checking for g++... g++
> configure: WARNING: using cross tools not prefixed with host triplet
> checking whether we are using the GNU C++ compiler... yes
> checking whether g++ accepts -g... yes
> checking how to run the C preprocessor... 
> /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/cpp
> checking for arm-apple-darwin-ranlib... no
> checking for ranlib... ranlib
> checking for a BSD-compatible install... /usr/bin/install -c
> checking whether ln -s works... yes
> checking whether make sets $(MAKE)... yes
> /Users/elliott/Programming/Lisp/ecl-iphone-builder/ecl-9.8.4/build/cross_config: 
> line 25: syntax error near unexpected token `)'
> /Users/elliott/Programming/Lisp/ecl-iphone-builder/ecl-9.8.4/build/cross_config: 
> line 25: `)'
> /Users/elliott/Programming/Lisp/ecl-iphone-builder/ecl-9.8.4/src/configure: 
> line 4336: -eval: command not found
> configure: error: The program ECL-MIN is not installed in your system
This is the error -- not sure why cross_config is malformed. I tried a 
rebuild just to verify (on a MacBook Pro running Snow Leopard (10.6.2), 
and it built correctly. You can look at the build output (from the link 
below) to see if there's anything that stands out:


I've also attached a working `ecl-9.8.4/build/cross_config' file from 
the build for reference. Hope that helps.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/ecl-devel/attachments/20091212/c1747e59/attachment.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cross_config
URL: <https://mailman.common-lisp.net/pipermail/ecl-devel/attachments/20091212/c1747e59/attachment.ksh>

More information about the ecl-devel mailing list