[Ecls-list] ECL-9.8.3 and latest from cvs not building with msvc

Luke J Crook luke at balooga.com
Thu Aug 13 21:48:07 UTC 2009

I tried building the version 9.8.3 from Sourceforge & the latest from cvs and 
get the same error below;

;;; Note: Invoking external command:
;;;   cl -I"C:/Documents and Settings/user/My Documents/download/apps/ecl/ecl
BUG /MD /O2 -DGC_BUILD   -w -c "C:/DOCUME~1/user/LOCALS~1/Temp/ECL25F.c" -Fo"

Unable to find library directory

Available restarts:

1. (QUIT-DEBUGGER) Quit debugger level 1.

Broken at TPL.
 File: #P"C:/Documents and Settings/user/My Documents/download/apps/ecl/ecl-9
.8.3/src/lsp/top.lsp" (Position #16059)
        c\cut "~A" "%CD%/package" "~*" ""  "@ECL_CFLAGS@" "/EHsc /DGC_DLL /DGC_B
ologo /nodefaultlib:libcmt /nodefaultlib:libcmtd /nodefaultlib:libc /nodefaultli
b:libcd /nodefaultlib:msvcrtd.lib"  "@CLIBS@" ""  "@libdir@" "%CD%/package"  "@i
ncludedir@" "%CD%/package/ecl"  < util\ecl-config.bat > ecl-config.bat
        c\cut "@ECL_CFLAGS@" "/EHsc /DGC_DLL /DGC_BUILD /nologo /D_CRT_SECURE_NO
_DEPRECATE /DNDEBUG /MD /O2"  "@LDFLAGS@" "/link /nologo /nodefaultlib:libcmt /n
odefaultlib:libcmtd /nodefaultlib:libc /nodefaultlib:libcd /nodefaultlib:msvcrtd
.lib"  "@CLIBS@" ""  "@libdir@" "%CD%/package"  "@includedir@" "%CD%/package/ecl
"  < util\ecl-cc.bat > ecl-cc.bat

More information about the ecl-devel mailing list