[Ecls-list] Strange error

Waldek Hebisch hebisch at math.uni.wroc.pl
Sat May 31 23:06:47 UTC 2008

Juan Jose Garcia-Ripoll wrote:
> On Sat, May 31, 2008 at 7:10 PM, Waldek Hebisch
> <hebisch at math.uni.wroc.pl> wrote:
> > AFAICS Fedora problem is triggered by security measures: when
> > I did (as a root):
> > echo 0 > /proc/sys/kernel/randomize_va_space
> > echo 0 > /proc/sys/kernel/exec-shield
> > then build went fine.
> I am a bit puzzled. Are you using the latest sources? I committed a
> patch today (explained in another email) that removes the call to
> si_gc() at the price of _not_ using the wrapper around dlopen() which
> is shipped with the Boehm-Weiser garbage collector. This way, the
> garbage collector is not deactivated when loading binary files and it
> should not run out of memory.

Well, I used CVS 2008-05-31 01:49.  Doing cvs update gave me the
same tag and the same build failure.
> Now, as for the two flags that you set up, if the problem is related
> to memory fragmentation, then only the first line should be needed.
> exec-shield, is related to making memory nonexecutable. If that was
> causing the problem, then we would see some other signals coming out,
> such as SIGBUS, I suppose.

Well, I reported what I did.  I retried setting exec-shield back to
1 (but keeping randomize_va_space at 0) and build still worked.

> Incidentally, I checked and the memory randomization feature is active
> in my server (Ubuntu/64), but I must admit I have not yet completed a
> full build of FriCAS.

Release type build worked with randomize_va_space set to 2, but
I get testsuite failures.  On Gentoo I have randomize_va_space set
to 1 -- build works and test (except for on or two) pass.  I am
now trying on Fedora setting randomize_va_space to 1 -- just now
build went further than all my attempts with randomize_va_space
set to 2.

                              Waldek Hebisch
hebisch at math.uni.wroc.pl 

More information about the ecl-devel mailing list