[Ecls-list] Still problems with compiling on Debian i686

css at swissjabber.ch css at swissjabber.ch
Fri May 9 16:15:50 UTC 2008

I used --build=i686-pc-linux, same for target and host. Yes, it
compiled. It seems to work now, so far. Thank you.

Another Problem I had was, that ECL doesnt find libecl.so in
/usr/local/stow/ecl-.../lib or - where it was symlinked to -
/usr/local/lib. I had to put the exact path in my
ld.conf.so.d/-Directory, but then it worked. I had a similar Problem
(on another Computer) when using the dynamic ffi. There, I had to set
the cffi-variable for this purpose. I have no Problem with this, but I
am not sure if this is the desired behavior, so I thought I should
tell it here.


2008/5/9, Dustin Long <dlong at progmatism.com>:
> Just throwing this out there... I was having similar problems a short time
> ago and got around them with this configure line:
> ./configure --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu
> --target=i686-pc-linux-gnu
> Maybe that'll work for you too?
> On Thu, May 8, 2008 at 4:58 PM, css <css at swissjabber.ch> wrote:
>> Hello again.
>> I still cannot manage to compile ECL on my laptop (debian lenny, i686,
>> kernel 2.6.24-1-686). I did a cvs update today (May 08, 2008). I am
>> meanwhile trying to compile using the following flags:
>> ./configure --build=i686 --prefix=/usr/local/stow/ecl-08-may-2008
>> --enable-threads --enable-debug --enable-unicode --with-clx
>> --with-serve-event --with-defsystem --with-profile
>> --enable-boehm=system
>> The lisp-core boots, seems to compile some functions, but stops with
>> the following output:
>> ;;; Note: Invoking external command:
>> ;;; gcc -o "/home/***/installers/ecl/build/libecl.so"
>> -L"/home/***/installers/ecl/build/" "c/main.o" "c/all_symbols2.o"
>> "liblsp.a" "libeclmin.a"         -lm   -lgc -lgmp
>> /usr/lib/gcc/i486-linux-gnu/4.2.3/../../../../lib/crt1.o: In function
>> `_start':
>> (.text+0x18): undefined reference to `main'
>> collect2: ld returned 1 exit status
>> LAMBDA: Too many arguments to function CONTINUE.
>> Broken at TOP-LEVEL. File:
>> #P"/home/***/installers/ecl/src/lsp/top.lsp" (Form #26)No restarts
>> available.
>> Top level.
>> SI> (quit)
>> make[1]: Leaving directory `/home/christoph/installers/ecl/build'
>> When I noticed that it says something about i486, i tried  it with
>> --build=i486, same error. I have no idea. libgc-dev is installed with
>> all dependencies! Any clues?
>> CSS
>> -------------------------------------------------------------------------
>> This SF.net email is sponsored by the 2008 JavaOne(SM) Conference
>> Don't miss this year's exciting event. There's still time to save $100.
>> Use priority code J8TL2D2.
>> http://ad.doubleclick.net/clk;198757673;13503038;p?http://java.sun.com/javaone
>> _______________________________________________
>> Ecls-list mailing list
>> Ecls-list at lists.sourceforge.net
>> https://lists.sourceforge.net/lists/listinfo/ecls-list

More information about the ecl-devel mailing list