[Ecls-list] Still problems with compiling on Debian i686

css css at swissjabber.ch
Thu May 8 20:58:01 UTC 2008

Hello again.

I still cannot manage to compile ECL on my laptop (debian lenny, i686,
kernel 2.6.24-1-686). I did a cvs update today (May 08, 2008). I am
meanwhile trying to compile using the following flags:

./configure --build=i686 --prefix=/usr/local/stow/ecl-08-may-2008
--enable-threads --enable-debug --enable-unicode --with-clx
--with-serve-event --with-defsystem --with-profile

The lisp-core boots, seems to compile some functions, but stops with
the following output:

;;; Note: Invoking external command:
;;; gcc -o "/home/***/installers/ecl/build/libecl.so"
-L"/home/***/installers/ecl/build/" "c/main.o" "c/all_symbols2.o"
"liblsp.a" "libeclmin.a"         -lm   -lgc -lgmp
/usr/lib/gcc/i486-linux-gnu/4.2.3/../../../../lib/crt1.o: In function `_start':
(.text+0x18): undefined reference to `main'
collect2: ld returned 1 exit status
LAMBDA: Too many arguments to function CONTINUE.
Broken at TOP-LEVEL. File:
#P"/home/***/installers/ecl/src/lsp/top.lsp" (Form #26)No restarts
Top level.
SI> (quit)
make[1]: Leaving directory `/home/christoph/installers/ecl/build'

When I noticed that it says something about i486, i tried  it with
--build=i486, same error. I have no idea. libgc-dev is installed with
all dependencies! Any clues?


More information about the ecl-devel mailing list