[Ecls-list] Problem with Building on debian i686

css css at swissjabber.ch
Thu Apr 24 19:34:50 UTC 2008

2008/4/24, Juan Jose Garcia-Ripoll <jjgarcia at users.sourceforge.net>:
> On Thu, Apr 24, 2008 at 6:17 PM, css <css at swissjabber.ch> wrote:
>  >  No. Same error.
>  Do you mean just doing "./configure
>  --prefix=/usr/local/stow/ecl-23-april-2008" does not create any file
>  in build/gc/ ?
>  If so, then the garbage collector is failing to recognize and
>  configure in your system. Possible clues should be in
>  build/gc/config.log and in build/config.log . One solution, without
>  looking at those files, is to install Debian's version of the garbage
>  collector using the package manager and try configuring ECL for that.

libgc-dev is installed, as libgmp2-dev is. In fact, all dependencies
of ecl (including their dev-packets) are installed. Still I get
exactly the same error. I dont understand what config.log sais. There
are a few "errors" mentioned, but I dont know what they mean.

For example:
configure:3498: g++ -c -g -O2  conftest.cc >&5
conftest.cc: In function 'int main()':
conftest.cc:17: error: 'exit' was not declared in this scope
configure:3504: $? = 1
configure: failed program was:
| /* confdefs.h.  */

configure:3454: g++ -c -g -O2  conftest.cc >&5
conftest.cc:13: error: 'void std::exit(int)' should have been declared
inside 'std'
configure:3460: $? = 1
configure: failed program was:
| /* confdefs.h.  */

Actually, I do not understand why this calls g++ and not gcc. I didnt
pass --with-cxx. But anyway, the same error remains. It seems neither
to recognize the local garbage collector (libcl), nore libgmp3-dev.


More information about the ecl-devel mailing list