[Ecls-list] c:build-program and -eval

Gabriel Dos Reis gdr at integrable-solutions.net
Sat Mar 10 09:02:15 UTC 2007


  I'm new to ECL, so my question may be an FAQ -- but I missed the
corresponding entry in the documentations.  I apologize in advance.

  I'm trying to test a Lisp system with ECL -- so far, I've been
able to use GCL, CLISP, and SBCL with success.  For the testing, the
ability to invoke ECL in "batch" more with -eval is quite essential.

  I tried to reproduce the examples 


using only the -eval option.  So far, I can compile hello.lisp to
an object file using the command:

% ecl -eval '(progn (compile-file "hello.lisp" :system-p t) (quit))'
;;; Loading #P"/home/gdr/lib/ecl/cmp.fas"
;;; Loading #P"/home/gdr/lib/ecl/sysfun.lsp"
;;; Compiling hello.lisp.
;;; End of Pass 1.  
;;; Calling the C compiler... 
;;; Note: Invoking external command:
;;; gcc  -D_GNU_SOURCE -g -O2 -fPIC  -fstrict-aliasing -Dlinux -O "-I/home/gdr/lib/ecl/" -w -c "/home/gdr/tmp/hello.c" -o "/home/gdr/tmp/hello.o"

;;; OPTIMIZE levels: Safety=2, Space=0, Speed=3
;;; Finished compiling hello.lisp.

However, the "c:build-program" step invariably fails, with error to
the effect that ECL cannot find the external symbol build-program from
package c.

% ecl -eval '(progn (c:build-progam "hello.lisp" :lisp-file (quote ("hello.o"))) (quit))'
An error occurred during initialization:
Cannot find the external symbol BUILD-PROGAM in #<"C" package>..

Notice that the same error occurs when I start eval afresh in
interactive mode and tries to complete the c:build-program step.
Any idea how to get that part work?

Thanks in advance,

-- Gaby

More information about the ecl-devel mailing list