[Ecls-list] build.vc8 files in mac format

Dustin Long dlong at stevens.edu
Mon Feb 12 10:48:03 UTC 2007

Dustin Long wrote:
> Juan Jose Garcia-Ripoll wrote:
>> 2007/2/12, Dean O'Connor <dean.oconnor at ite.com.au>:
>>> Yes, it certainly seems to be a TortoiseCVS problem at least on my x64
>>> machine. [...]
>>> May I ask what Windows (x32/x64?) and TortoiseCVS version you tried ?
>> Actually, I had the same problem with TortoiseCVS "stable" on a XP
>> Home with 32 bits. The machine, though, is a Core 2 Duo, so it
>> definitely has 64 bit registers available, but I doubt one can use
>> them under Windows, may one?
>> Are there any other CVS clients around, other than cygwin/mingw32?
>> Would it make sense to make nightly CVS snapshots, then? This could be
>> another reason to provide a continously updated mirror using
>> mercurial, though.
>> Cheers,
>> Juanjo
> For my own projects, I've been using this guy:
> http://www.cvsnt.org/wiki/Download
> Haven't tried it on ecl yet. I'm building the latest pull from cvs now 
> to see if it exhibits any of the reported problems that Tortoise had, 
> and will report the news when it finishes.
> Dustin
That builds just fine without threads.

With threads, in order to get ecl_min to link I had to add 
$(THREADS_OBJ) to the OBJS= line in msvc/gc/Makefile and I'm still 
getting an error well into the build:


;;; Note: Invoking external command:
;;; cl -MD -EHsc -DGC_DLL -nologo -DECL_THREADS -DGC_BUILD  -I"../src"/c 
-I"../src"/h -I"D:/home/dev/src/ecl/ecl/msvc"  
-I"D:/home/dev/src/ecl/ecl/msvc" -w -c 

;;; OPTIMIZE levels: Safety=2, Space=3, Speed=1
;;; Finished compiling src:cmp;cmpmain.lsp.
;;; Note: Invoking external command:
;;; cl -MD -EHsc -DGC_DLL -nologo -DECL_THREADS -DGC_BUILD  -I"../src"/c 
-I"../src"/h -I"D:/home/dev/src/ecl/ecl/msvc"  
-I"D:/home/dev/src/ecl/ecl/msvc" -w -c 

Unable to find library directory
Broken at TOP-LEVEL.No restarts available.
Top level.
        c\cut "~A" "D:/Software/ECL/lib/ecl" "~*" ""  "@ECL_CFLAGS@" 
"-MD -EHsc
-DGC_DLL -nologo -DECL_THREADS"  "@LDFLAGS@" "-MD /link 
/nodefaultlib:libcmt /no
defaultlib:libcmtd /nodefaultlib:libc /nodefaultlib:libd"  "@CLIBS@" ""  
r@" "D:/Software/ECL"  "@includedir@" "D:/Software/ECL/ecl"  < 
at > ecl-config.bat
        c\cut "@ECL_CFLAGS@" "-MD -EHsc -DGC_DLL -nologo -DECL_THREADS"  
GS@" "-MD /link /nodefaultlib:libcmt /nodefaultlib:libcmtd 
/nodefaultlib:libc /n
odefaultlib:libd"  "@CLIBS@" ""  "@libdir@" "D:/Software/ECL"  
"@includedir@" "D
:/Software/ECL/ecl"  < util\ecl-cc.bat > ecl-cc.bat


I can see ECLINITa02308, ECLINITa02308.c, and ECLINITa02308.obj in my 
temp directory. I have no idea what the error means but will continue to 
look into it. I'm using msvc6 on winxpsp2.


More information about the ecl-devel mailing list