[Ecls-list] New User on Windows Struggling

Goffioul Michael goffioul at imec.be
Mon Sep 4 08:35:59 UTC 2006

The generic installation procedure can be the following:
1) make sure you have a working Windows development environment:
    - either you have Visual Studio
    - or you download/install free Windows compilers available and
Platform SDK
2) start a command prompt with correct environment:
    - usually, the compiler/SDK installation dirs contain batch script
to setup
      everything (VC6: VCVARS32.BAT, .NET SDK: sdkvars.bat, ...)
3) edit msvc\Makefile to configure the target installation dir (change
the "prefix"
5) NMAKE flatinstall
Note: the software version is just indeed not the right one, the
Makefile should
be updated.


	From: ecls-list-bounces at lists.sourceforge.net
[mailto:ecls-list-bounces at lists.sourceforge.net] On Behalf Of Sean D
	Sent: Tuesday 22 August 2006 14:54
	To: ecls-list at lists.sourceforge.net
	Subject: [Ecls-list] New User on Windows Struggling
	I have decided to adopt ECL as my Lisp. I tend to use Windows
exclusively. I have downloaded the latest version of ECLS and tried
following the instructions for installing and making but with no luck so
far. Information and problems I have noticed: 
	1. I use pure windows - no cygwin etc.
	2. I can only use the free versions of C++ 
	3. The instructions for installing on Windows seem to be
outdated as there are newer versions of the SDK, C++ compiler,  .NET
framework and .NET SDK. 
	4. The .NET SDK requires a prior install of software - no
mention is made of this.
	5. The MAKEFILE has latest software as 0.9h although it is 0.9i
	6. The links provided by ECLS in the install.html file and on
the website appear to be outdated. 
	7. Mention is made of copying libraries from the the .NET SDK to
the C++ directories - but these libraries already exist in the C++ lib
directory and have a more recent timestamp and different sizes.
	8. The NMAKE file pointed to doesn't seem to install to a
specific directory but just to the current directory - also a newer
NMAKE.exe already exists in the free version of C++
	I tried as many combinations as I could - for example older
NMAKE with older libraries and other combinations but I don't have a
clue as to why I am doing the things I am! 
	I would be more than happy to update the documentation etc. once
I can get my system working and understand better what I am trying to
do, but looks like I need lots of help getting there!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/ecl-devel/attachments/20060904/d30495f5/attachment.html>

More information about the ecl-devel mailing list