[Ecls-list] HELP: Building in OpenBSD v3.9 AMD64 fails

Pekka Niiranen pekka.niiranen at wlanmail.com
Sun Jun 11 13:43:00 UTC 2006

Hi there,

I downloaded cvs -version of ECL and tried to to compile that in
OpenBSD v3.9/AMD64. I tried it in 3 different ways:

1)	./configure && make
	The result was:

	gcc -fPIC -DPACKAGE_NAME=\"gc\"
	-DATOMIC_UNCOLLECTABLE=1 -I/home/pekka/srcs/ecl/src/gc/include
	-fexceptions -g -O2 -fPIC -fstrict-aliasing -fexceptions
	-MT allchblk.lo -MD -MP -MF .deps/allchblk.Tpo
	-c /home/pekka/srcs/ecl/src/gc/allchblk.c -o allchblk.o
	In file included from
	from /home/pekka/srcs/ecl/src/gc/allchblk.c:19:
	error: syntax error before '--' token
	In file included from
	from /home/pekka/srcs/ecl/src/gc/allchblk.c:19:
	unterminated #ifndef
	unterminated #ifndef
	In file included from /home/pekka/srcs/ecl/src/gc/allchblk.c:19:
	unterminated #ifndef
	unterminated #ifndef

2)	I installed package "boehm-gc-6.2p1.tgz" and tried to compile
	ECL with:

		./configure --enable-boehm=system

	The result was:
	checking for library containing strerror... none required
	checking for GC_malloc in -lgc... no
	configure: error: System Boehm GC library requested but
	not found.

3)	Finally I tried (explained in ecls-list by Juan Jose Garcia

	CFLAGS="-I/usr/local/lib -g -O2" LDFLAGS="-L/usr/local/lib" \
	./configure --prefix=/usr/local --enable-boehm=system

	The result was:

	checking for tzset... yes
	checking gc.h usability... no
	checking gc.h presence... no
	checking for gc.h... no
	checking gc/gc.h usability... no
	checking gc/gc.h presence... no
	checking for gc/gc.h... no
	configure: error: Boehm-Weiser garbage collector's headers \
	not found

Any ideas anybody?



More information about the ecl-devel mailing list