[Ecls-list] Compile of ecl 0.9d on NetBSD/Mac68k softfloat

Bruce O'Neel edoneel at sdf.lonestar.org
Wed May 18 08:43:29 UTC 2005


My carry around computer is an old Apple Powerbook 540.  These
have the 68LC040 processors in them which do not have the

Since I run NetBSD on it I did a build this past weekend of 0.9d.  It
only took about 15hrs to build.  I tried 0.9e but it failed on one of
my other NetBSD boxes (a faster one) and I didn't look too deeply yet
into why it failed.

Basically once I set CC to gcc -msoft-float all of ecl
built fine.  I had 2 problems while building.

- NetBSD/m68k sadly defines struct frame in some header
file which gets included when you #include <signal.h>.
I solved this by changing frame to cpuframe in the NetBSD
header files.  Seems like a silly choice for a system
header file.

- I got illegal instruction faults when emitting code for
3 different lsp files.  I hand built those from the .c/.h files
built on another system.  I'll look into this over the
next weeks.

- A general NetBSD problem was that I couldn't configure with 
--tcp=yes and then get a working ecl.  It kept crashing.

There seem to be two runtime problems. 

- The reader can't seem to let you floats.  Floats work
once entered (ie (float (/ 1 10)) gives the right answer)
but (/ 1.0 10.0) does not.

- bignums seem broken.  I wonder if that's not the same problem 
as the one that cropped up during compiling.

Overall I'm very pleased.  Thanks!  If I get a chance and find these
problems I'll send some sort of additional email.  I like very much
having the same environment on all my systems (ppc, i386, sparc, and



edoneel at sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

More information about the ecl-devel mailing list