[Ecls-list] Looking for a non-existing C header file

Moshe Goldstein goldmosh at fh.huji.ac.il
Mon Nov 11 06:50:02 UTC 2002

Dear list members:
I successfully installed ECL in a Linux machine.
I tried it as a regular read-eval-print Lisp interpreter and it is also
I wrote some trivial functions in a Lisp source file, loaded and
executed the functions inside it, and it also was OK.
Then, I tried to compile the same Lisp source file and I have the
following problem:

Being in the prompt of the interpreter, I executed the following:
(compile-file "mapsquare.lsp" :verbose T)

The compiler printed the following messages:

;; Compiling mapsquare.lsp.
;;; Compiling (DEFUN SQUARE ...).
;;; Compiling (DEFUN SQUARE_MAP1 ...).
;;; Compiling (DEFUN SQUARE_MAP2 ...).
;;; Compiling (DEFUN SQUARE_MAP3_AUX ...).
;;; Compiling (DEFUN SQUARE_MAP3 ...).
;;; End of Pass 1.
;;; Emitting code for SQUARE.
;;; Emitting code for SQUARE_MAP1.
;;; Emitting code for SQUARE_MAP2.
;;; Emitting code for SQUARE_MAP3_AUX.
;;; Note: Tail-recursive call of SQUARE_MAP3_AUX was replaced by
;;; Emitting code for SQUARE_MAP3.
;;; Calling the C compiler...
"gcc -g -O2 -Dlinux  -O
-I/usr/people/benny10/goldmosh/myusr/local/lib/ecl//h -w -c mapsquare.c
-o mapsquare.o"
In file included from
gmp.h: No such file or directory

(SYSTEM "gcc -g -O2 -Dlinux  -O
-I/usr/people/benny10/goldmosh/myusr/local/lib/ecl//h -w -c mapsquare.c
-o mapsquare.o") returned non-zero value 1

The gcc compilation failed because the header file gmp.h does not exist.

I looked for it in the installation directories and I did not find it.
Where is it supposed to be?
If it had to be included in the ECL distribution, please could you send
it to me?

Thank you.

-- Moshe Goldstein

More information about the ecl-devel mailing list