Cannot log in as vsedach at after added SSH key to Gitlab

Vladimir Sedach vsedach at
Sat Jul 1 21:12:26 UTC 2017


I ran into a strange problem:

I added a new ed25519 key to authorized_keys2, which worked fine. Then I
went to Gitlab web interface and tried adding the ed25519 key, which
failed because Gitlab cannot handle ed25519 keys yet. I made a new RSA
key and added that in the Gitlab web interface. After this I cannot log
into vsedach at with any of the keys that were in
authorized_keys2. The error message is "Permission denied (publickey)"
so something must have happened to the authorized_keys file.

This seems very strange. I do not think I did anything as
vsedach at that would break log-ins, which leads me to
believe that it was some script in Gitlab. OTOH the new RSA key does not
work either, so it might be something I did through TRAMP by accident.

Can you please put this SSH key into authorized_keys:

ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIDc+4x1XblOzyfHAzOCbM00FB/VglYg0PvOSL8FuQKQ/ vas at t43.lan.

Thank you,

More information about the clo-devel mailing list