Registering a new project

Jean-Claude Beaudoin jean.claude.beaudoin at
Wed Jul 3 08:31:34 UTC 2013

On Wed, Jul 3, 2013 at 3:54 AM, Marco Antoniotti <marcoxa at> wrote:

> On Jul 3, 2013, at 04:11 , Raymond Toy <toy.raymond at> wrote:
> >>>>>> "Marco" == Marco Antoniotti <marcoxa at> writes:
> >
> >    Marco> Dear all,
> >    Marco> I want to register a new project on  Alas,it
> appears that the address <admin [to]> is non functional.
> >
> >    Marco> Incidentally, how is git support working at this point?
> >
> > Git seems to be working fine for me.  I haven't had any issues with
> > cmucl or my other repos.
> Yes. My old repositories work fine.  However, I do not quite understand
> how to set up push/pull locations.

For MKCL I have my main Git repository on and I run a clone of
it on as a mirror.
The MKCL page on mentions that mirror repository and has a
link to browse it through gitweb
(I like the look of gitweb better than the github equivalent, that is
probably the only advantage of having
a repository on beside some level of redundancy.)

There used to be a cron job on that would synchronize
automatically the local mirror
repository against its "origin" every 4 hours if setup right but that has
been broken since April 23, 2013
(I presume this is a consequence the power outage crash the
common-lisp.netmachine experienced
around that time.)

I sent an email to this list on that very subject last May 23 (I copied it
here below) but it has been
ignored to this day. In the meantime I worked/hacked out a private version
of the cron script and
I get my local repository synchronized with it every now and then,
triggering it manually.


Jean-Claude Beaudoin

Updating of GIT repositories mirrored on is broken
Jean-Claude Beaudoin <jean.claude.beaudoin at>

     May 23, 2013

to clo-devel
For projects that mirror their GIT repositories on it looks very much like the automatic
(cron based) updating has been broken since last April, 23.

I think the problem comes from a stale lock file named in directory /custom/run.
Could someone with root access remove that stale lock
and assure that the updating script can then run properly?


Jean-Claude Beaudoin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the clo-devel mailing list