[cl-cairo2-devel] modifying cl-cairo2-swig.lisp

Johann Korndoerfer cupe-cl-cairo2 at erleuchtet.org
Sat May 31 23:00:00 UTC 2008


hi

Tamas K Papp wrote:
> I think that the change to keywords you suggested is very sensible [...]
> if you feel you would like to do it and submit a patch

After poking around i found the table mechanism quite unnecessary
because the cenums could just be renamed to something prettier. I did
that (completely emptying the tables.lisp) and also changed the naming
scheme of the cfuns from cairo_foo_bar to cairo-foo-bar to make them
more pleasing to the eye (mine at least), so now the only file
containing underscores is cl-cairo2-swig.lisp. changing this file means
that it will no longer be possible to generate cl-cairo2-swig.lisp with
swig, leading to the obvious disadvantage that catching cairo api
changes will not be as easy as before. i still think it is worth it
since the code has become much more simple and readable in my opinion
and we can always easily extend the file when cairo's api is extended,
which should not be that often. this is of course very debatable :)


This patch also constitutes an api change: instead of

(cl-cairo2:create-image-surface 'cl-cairo2:format-argb32 23 42))

the user will have to write

(cairo:create-image-surface :argb32 23 42))

and similarly for font weight etc. The examples and the tutorial have
been updated to reflect this change. I also added :cairo as a nickname
for the package and fixed some minor bugs i stumbled upon.

Since i will be needing patterns, i have started a pattern.lisp which i
will submit as soon as it is complete.

greetings
johann
-------------- next part --------------
A non-text attachment was scrubbed...
Name: tables-removed.tar.gz
Type: application/x-gzip
Size: 15898 bytes
Desc: not available
URL: <https://mailman.common-lisp.net/pipermail/cl-cairo2-devel/attachments/20080601/443b6e3f/attachment.bin>


More information about the Cl-cairo2-devel mailing list