[Bese-devel] LispWorks and UCW

Juergen Gmeiner gj at gjdv.at
Tue Apr 5 12:27:39 UTC 2005

Marco Baringer wrote:
> Friedrich Dominicus <frido at q-software-solutions.de> writes:

>>Now it happens that this has failed for some symbols, but I suppose
>>that should not have happened. I know that the following is just a
>>hackerish solution to the problem:

> odd. apparently our provide-mopp-symbol isn't doing what it should. it
> would be very helpfull if you: 1) trace mopp::provide-mopp-symbol 2)
> reload mopp.lisp 3) check what (find-symbol (string
> 'mopp::standard-class) :CLOS) returns.

i ran into the same problem as friedrich dominicus, my solution
is attached in arnesi.patch (i use a current ucw from the darcs repo,
and a downloaded 0.3.7 for arnesi/yacml/... - so maybe this is already
fixed in a "current" arnesi.

additionaly, my most annoying problem was errors (like the error
example) would hang the server process by entering an endless loop
(at least when working in the ide instead of via slime).
i tracked down the problem in the slime code, see slime.patch

i will submit the slime patch to the slime-maintainers as well,
but i think that ucw uses the backtracking stuff differently than
slime does internally ... so this is probably not a problem for them,
and it may or may not make it in.

also, a couple of typos/small stuff i ran into with ucw.
- lispworks can do threading ... although it has to be enabled
     (development images do this by default thought).
     better would be to check if it has been enabled
- if running ucw without threading and an error occurs, aborting
     will kill the listener, and the associated log streams will not
     work anymore.  trying to shutdown the server (so the socket is freed)
     from a new listener will not work because the logging signals an error
- presentations.lisp will not compile with :accessor :decimal-sperator
- i also have tbnl loaded, and tbnl also comes with rfc2388. as
     tbnl's version is "improved" (additional optional arguments) but
     backwards compatible, i read-time conditionalized the dependency

also a question: it would be instructive to look at a "real"
ucw application's source ... is there any large open-source
application that uses ucw?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: arnesi.patch
Type: text/x-patch
Size: 1421 bytes
Desc: not available
URL: <https://mailman.common-lisp.net/pipermail/bese-devel/attachments/20050405/3905edd8/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ucw.patch
Type: text/x-patch
Size: 2082 bytes
Desc: not available
URL: <https://mailman.common-lisp.net/pipermail/bese-devel/attachments/20050405/3905edd8/attachment-0001.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: slime.patch
Type: text/x-patch
Size: 1367 bytes
Desc: not available
URL: <https://mailman.common-lisp.net/pipermail/bese-devel/attachments/20050405/3905edd8/attachment-0002.bin>

More information about the bese-devel mailing list