[E] Re: new compiler error re: SET-DISPATCH-MACRO-CHARACTER

Konstanski, Carlos carlos.konstanski at verizonwireless.com
Thu Oct 12 03:19:56 UTC 2017

puri was pulled into my system by quicklisp as s dependency of drakma, and
asdf was installed by portage. I have never written a line of lisp that
called puri directly. No one is ever persuaded by the "it works for me"
argument. The issue is real. Are you using a clean install of asdf, uiop
and puri? Or are you using your development branch of asdf? Developers can
always get it to work on their workstations. Maybe it's the gentoo package
for asdf or uiop. Maybe slime is providing some sort of wrapping
environment that affects readtables. There are any number of things that
could be at play that are beyond the user's control.

Let's say you are right in saying that puri is doing something naughty by
polluting a readtable. I'll go along with that. I have no reason to doubt
it. I'm on your side on this issue. Nevertheless we have a problem: this
code has been in the wild since 2015 or earlier. A very ubiquitous library
(drakma) depends on it. Cleaning up poor behavior is a bigger job than
making a fundamental and core component like asdf no longer accept the
behavior. The offending libraries have to be fixed in concert with this
refactoring. Established libraries cannot simply have the rug pulled out
from under them.

I'm with Stas. I cannot upgrade asdf if it makes it impossible for me to
use libraries that I depend on. Whatever new things asdf does are less
important to me than having a working drakma. I believe just about all
users would agree with this sentiment.

I'm perfectly willing to contribute to the fixing of these libraries. But
let's not do it as a mad scramble. Let's issue deprecation warnings,
identify broken quicklisp packages, get the bugs in those packages fixed
and then implement the new asdf behavior. I'm here to help.


2017-10-11 20:31 GMT-06:00 Faré <fahree at gmail.com>:

> I just tried compiling puri with asdf 3.3.0, using either quicklisp or
> the latest commit (b537e93 from August 29 2015) on sbcl 1.3.20, and
> had no issue whatsoever.
> Odds are the problem is on your side, probably with your using
> with-standard-io-syntax or some such. Note that it is very rude to use
> set-dispatch-macro-character on a readtable you didn't specifically
> setup, especially since it might be a read-only readtable, or worse, a
> writable one used by people who assume it won't be modified.
> I've had a branch of ASDF, called "syntax-control", supposed to bring
> *some* sanity in readtables used while building with ASDF. It has
> bitrotten in the last 4 years and is nowhere near being merged at this
> point.
> —♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics•
> https://urldefense.proofpoint.com/v2/url?u=http-3A__fare.
> tunes.org&d=DwIFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LR
> xpb6__0PomBTQ&r=UXttlWX_R8MsWhBAnFwO2t5aPuH2x7HGk4gZpT
> TCo-UE-RFLppFABNHDw29AmFnQ&m=sNgypPrTU-ocowWcZQAmsxdniF2mxBwl_
> 6BmfJxiyjY&s=8O9az24Gmg12t9C9jp5bOiJSXjwPqkIvmeFuYqIUCnw&e=
> Opportunity is missed by most people because it comes dressed in overalls
> and looks like work.    — T. A. Edison
> On Wed, Oct 11, 2017 at 8:41 PM, Konstanski, Carlos
> <carlos.konstanski at verizonwireless.com> wrote:
> > This is a bug report. I'm using puri as an example, but it's not a puri
> > bug.
> >
> > With the latest version of asdf (3.3.0) puri no longer compiles. The
> > following compiler error is thrown:
> >
> >    SET-DISPATCH-MACRO-CHARACTER would modify the standard readtable.
> >
> > In:
> >
> > #<READTABLE {100002D6C3}>)
> >
> > The code:
> >
> > (defun sharp-u (stream chr arg)
> >   (declare (ignore chr arg))
> >   (let ((arg (read stream nil nil t)))
> >     (if *read-suppress*
> >         nil
> >       (if* (stringp arg)
> >          then (parse-uri arg)
> >          else
> >          (internal-reader-error
> >           stream
> >           "#u takes a string or list argument: ~s" arg)))))
> >
> > (set-dispatch-macro-character #\# #\u #'puri::sharp-u)
> >
> > What puri is doing re: SET-DISPATCH-MACRO-CHARACTER is totally by the
> > book. Why is this suddenly an error? Is there a workaround?
> >
> > Backing up to the next most recent release of asdf makes the problem go
> > away:
> >
> > dev-lisp/asdf-3.2.1-r1:0/3.2.1-r1
> > dev-lisp/uiop-3.2.1:0
> >
> > I tried to find the asdf changelog to see if this is a documented
> > change. But the link is broken.
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__common-
> 2Dlisp.net_project_asdf_Changelog&d=DwIFaQ&c=
> udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=UXttlWX_
> R8MsWhBAnFwO2t5aPuH2x7HGk4gZpTTCo-UE-RFLppFABNHDw29AmFnQ&m=sNgypPrTU-
> ocowWcZQAmsxdniF2mxBwl_6BmfJxiyjY&s=-Ety3cawXfSBOqWK_
> Ms5Hi2TwB62089buk66HVbLu-s&e=
> >
> > uiop seems to be closely tied to asdf. Not sure which package is
> > actually at fault.
> > --
> > Carlos Konstanski
> >

Carlos Konstanski
Verizon Cloud Platform
carlos.konstanski at verizonwireless.com
Cell: 15126218301
Slack: vzw-vsi.slack.com username: @ckonstanski
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/asdf-devel/attachments/20171011/ada57480/attachment-0001.html>

More information about the asdf-devel mailing list