Test results

Elias Pipping pipping.elias at icloud.com
Tue Sep 13 07:50:55 UTC 2016

> On 13 Sep 2016, at 03:47, Robert Goldman <rpgoldman at sift.net> wrote:
> On 9/12/16 Sep 12 -6:13 PM, Elias Pipping wrote:
>>> On 12 Sep 2016, at 23:33, Robert Goldman <rpgoldman at sift.net> wrote:
>>> I ran the tests again on all three platforms.
>>> Linux:
>> I’ve run tests on Linux again, now, too.
> Are you running on head of master from common-lisp.net?

Yes. I was testing with

>>> Unexpected test success on ecl-bytecodes (ECL 16.1.2) in this block:
>>> ;; forced, it should be later
>>> (DBG "Check that force reloading loads again")
>>> (setf test-package::*file3* :reset)
>>> (load-system 'test-asdf/force :force :all)
>>> (assert-compare (>= (get-file-stamp file1) file1-date))
>>> (assert-equal test-package::*file3* t)
>>> I do *not* see this on ECL non-bytecodes.  The tests here fail as before.
>> I’ve hit the following regressions, some of which overlap with what you see:
>> - ECL 16.1.2 and newer fail test3.script in regular mode
>> - ECL 16.1.2 and newer fail test-force.script in ecl_bytescodes mode(+)
> I believe that this is a non-failure -- previously this was tagged as an
> expected failure.  Looks like Faré has removed that expected failure.
> Now ecl_bytecodes reports success on both Mac and Linux.  This is 16.1.2.
> I don't see a failure in test3.script, on either Mac or Linux.

Yikes. Now I cannot reproduce this issue anymore either all of a sudden. No idea what changes since yesterday. Will report back if/when the problem re-occurs.

>> - SBCL 1.1.13 now fails plenty of tests (11 to be precise). SBCL 1.3.9 and later are fine(++)
> The last time I checked SBCL 1.3.9 (really a candidate for release), it
> failed because of some pathname-printing code. Passes for me now on Mac
> and Linux.

That was a regression that they fixed prior to the 1.3.9 release, fortunately. I just wanted to point out here that so far rather old sbcl releases worked perfectly well and now they don’t. Might be worth investigating what changed.

>> - MKCL-git(*) now fails test-make-build.script and test-program.script(**)
> mkcl from git just now doesn't fail any tests for me.

Please make sure that you’re on the very latest mkcl (in particular, this will typically require you to pull from github, not the gitlab mirror). Please also make sure to remove any trace of the old installation from your system before installing a new version so that files the were removed are really gone.


More information about the asdf-devel mailing list