Version has been pushed

Faré fahree at
Wed Nov 16 14:24:21 UTC 2016

Would it be some ASDF extension you use that tries to instantiate
OPERATION without going through MAKE-OPERATION?

I tried to run your script, but it expects me to setup a
DWIM_WORKSPACE in a way that seems to be undocumented.

I tried to build projectured with its build script, and that works
fine for me... until it tries to find .so's in /usr and such, which
doesn't work with NixOS. :-( [Previously worked fine in Ubuntu.]

Also, after loading ASDF, your scripts could do this:
  --eval "(ignore-errors (load (uiop:subpathname
(user-homedir-pathname) \"quicklisp/setup.lisp\")))" \

—♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics•
To distinguish the real from the unreal, one must experience both. — Saul Gorn

On Wed, Nov 16, 2016 at 6:49 AM, Attila Lendvai <attila at> wrote:
>> Please try it out.  Working towards a release of ASDF soon, so anything
>> you could do to help iron out bugs would be very much appreciated!
> i did a thoughtless git checkout and rebuild, and i got the attached
> backtrace.
> the issue is with the new ban on operation instances. note that it
> seems to happen during an upgrade of ASDF itself, which may or may not
> be relevant.
> maybe for a while it should only be a full warning?
> my script is basically a build script for an executable SBCL image
> that loads all dependencies of our projects except our projects
> themselves. the dependencies come from the a mixture of the latest of
> quicklisp and my workspace.
> hope this helps,
> --
> • attila lendvai
> • PGP: 963F 5D5F 45C7 DFCD 0A39
> --
> “Nobody in the world, nobody in history, has ever gotten their freedom
> by appealing to the moral sense of the people who were oppressing
> them.”
> — Assata Shakur (1947–)

More information about the asdf-devel mailing list