Robert P. Goldman
rpgoldman at sift.info
Sat Mar 15 21:47:40 UTC 2014
>> In that case, maybe instead of trying to take a real English word that
>> > already has a meaning, we should take a short phrase that means exactly
>> > what we will do:
>> > DO-DEFAULT-OPERATION-ON-SYSTEM
>> > to be shortened to
>> > DDO
>> > [I don't like DoS or DDoS for obvious reasons! ;-)]
>> > I think DEFAULT-OP is a better name than BUILD-OP because it says what
>> > it means.
> While semantically correct, that is quite ugly, and ultimately not
> very helpful, because it fails to convey intent to someone who is not
> familiar with ASDF already, and someone who is familiar doesn't need
> to be reminded such thing.
Well, but consider this hypothetical person who doesn't know what's
going to happen and who isn't familiar with ASDF already.
S/he types (asdf:make "foo") and *either* gets foo loaded into his/her
lisp image or.... an executable file gets dropped onto his/her disk?
This is going to be confusing no matter *what* word we use.
I can't imagine why we would want to have a command that is "either
build or run or do something else with this system."
To be honest, I am not too hung up over this proposed command, simply
because I can't imagine myself ever wanting to use it instead of
LOAD-SYSTEM, because I don't see the utility of issuing a command that
will do something that I don't know and can't predict. Or more
accurately, that MIGHT do what I expect and might do something radically
It seems like you have two objectives with this build operation:
1. Have a default command. This seems primarily useful for systems
that will *not* be loaded, and where the user expects something else to
happen. In that case, it seems to me we would be better off NOT making
this mostly be an alias to LOAD-SYSTEM. If LOAD-SYSTEM is the right
thing, we should just tell ASDF to load the system.
2. Make a *shorter* alias to LOAD-SYSTEM. This seems to me to be a
different objective than #1, and I'm not sure trying to achieve both
with a single new addition to ASDF is The Right Thing.
More information about the asdf-devel