[Asdf-devel] Moving MKCL's bundled version to ASDF 3.1.2

Faré fahree at gmail.com
Fri Jun 20 13:40:24 UTC 2014

On Fri, Jun 20, 2014 at 6:11 AM, Jean-Claude Beaudoin
<jean.claude.beaudoin at gmail.com> wrote:
> I dropped in ASDF 3.1.2 from the release tarball in the MKCL 1.1.9
> source tree as a direct replacement of the currently bundled ASDF.
> It compiled fine. The whole MKCL build completes and installs as usual.
> The thus resulting ASDF 3.1.2 reports all tests are good when
> 'make test l=mkcl" is run, as well as with 'make test-upgrade l=mkcl'.
> But when I come to try an upgrade from 3.1.2 to syntax-control
> branch I then get a crash.  Here is attached the transcript of what
> is produced at the repl.
> The error message basically says that 'build/asdf.lisp' cannot be found.
> And in fact it is missing (it used to be produced properly by
> If I drop to a shell prompt and do make build/asdf.lisp and try the
> same upgrade again then it completes properly. So is there something
> broken now with the ASDF bundle 'concatenate' ops?
I suspect you are not bootstrapping ASDF properly;
that would explain why your patch didn't fix things at first,
but worked when I tried to reproduce: only the second time around
would ASDF have been properly built.
Most implementations "just" check in asdf.lisp.
If you checkout the whole tree, you need to create asdf.lisp by running "make".

> Would do but I don't quite understand how to fix what I just reported here
> above.
Please make sure you build asdf before you use asdf.
asdf is not magical: it needs either make or asdf to build asdf.
If you don't have asdf yet and try to build asdf, you're in trouble —
unless you use make to escape the bootstrap loop.

>> PS: minor issue, but when I (quit), I get this annoying message:
>> > (quit)
>> ;; MKCL shutdown: Thread refused to be interrupted: Sleeping thread:
>> #<thread "Imported thread pool filler daemon" active detached (27380)
>> 0x7f1aa19d0700 0000000003286000>, in file threads.d at line 1076.
>> ;; MKCL shutdown: Killing thread #<thread "Imported thread pool filler
>> daemon" active detached (27380) 0x7f1aa19d0700 0000000003286000>.
> Thanks for the report. I bet you get this only once in a blue moon. It is
> just
> a harmless annoyance. It also just reminds me that there is still some
> practical
> reality of thread programming I have come to terms with.  It is the very low
> frequency
> combined with clear randomness that bothers me. I just have get back to it
> and silence this nagger for good...
It happens more than "once in a blue moon".
Order of  magnitude 5% of invocations of mkcl.

—♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics• http://fare.tunes.org
Life is like an onion: you peel off layer after layer,
then you find there is nothing in it.

More information about the asdf-devel mailing list