[asdf-devel] (asdf:system-source-directory :uiop) not working after upgrade to

Dave Cooper david.cooper at genworks.com
Tue Oct 22 05:00:57 UTC 2013

> >
> > The way I install asdf for trying to use it in production is:
> >
> >  1. git pull into my local asdf directory.
> >  2. make (to make a single asdf.lisp file in asdf/build/)
> >  3. copy this to quicklisp/asdf.lisp
> >  4. rm -r quicklisp/cache
> >  5. edit quicklisp/setup.lisp to say:
> >      (defvar *required-asdf-version* "")
> >  6. copy the uiop/ directory from local asdf/ into
> quicklisp/local-projects/
> >  7. restart the Lisp
> >  8. load quicklisp/setup.lisp and (ql:register-local-projects)
> >
> > Having done all this, the (asdf:system-source-directory :uiop) still
> returns
> > nil, and uiop is not ending up in my monofasls which depend on it.
> >
> > Am I doing it wrong?
> >
> It looks right, or at least defensible.
> Did you copy the contents of version.lisp-expr in uiop/
> or a symlink that's now dangling? That could make a difference,
> though I would expect a more noisy failure.

So I went ahead and tried

  (load (compile-file "quicklisp/asdf.lisp"))

before loading quicklisp/setup.lisp.

And yes, I copied version.lisp.expr into quicklisp/local-projects/uiop/.

To test that it wasn't ignoring the uiop in local-projects because it is
the same version as what is already loaded, I even temporarily bumped the
version number in that version.lisp-expr to

Still no dice -- I still get

 (asdf:system-source-directory :uiop)   --> nil

after loading the quicklisp/setup.lisp and (ql:register-local-projects)

Quicklisp works in general after the upgrade. It just can't find the source
directory (or any source directory) for :uiop.

It's not crucial that I release with this latest, but I just bring
up this issue in case it is actually a lurking asdf bug which needs to be
shaken out before 3.0.3 release...

My Best,

Dave Cooper, Genworks Support
david.cooper at genworks.com, dave.genworks.com(skype)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/asdf-devel/attachments/20131022/95f05f01/attachment.html>

More information about the asdf-devel mailing list