[asdf-devel] Problem with CMUCL 20e and ASDF

Faré fahree at gmail.com
Sat Oct 5 18:59:49 UTC 2013

Dear Pascal,

while we're at it, since you are one of the few users of "logical"
pathnames in the world, your feedback is most welcome as to what does
or doesn't work in such a setting. There are now tests for logical
pathnames in ASDF, but I doubt they cover all the cases, so there may
be "interesting" failures despite all our best efforts.

—♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics• http://fare.tunes.org
Few facts are more revealing than the direction people travel
when they vote with their feet. — Don Boudreaux http://bit.ly/afZgx2

On Sat, Oct 5, 2013 at 12:05 PM, Pascal Costanza <pc at p-cos.net> wrote:
> On 5 Oct 2013, at 15:41, Zach Beane <xach at xach.com> wrote:
>> Pascal Costanza <pc at p-cos.net> writes:
>>> OK, found it. Apparently, you cannot use "~" in ASDF configurations
>>> anymore.
>> ~ syntax has never worked in CMUCL pathnames before. Did it start
>> working in 20e?
> I guess not. I test Closer to MOP on CMUCL only on major releases, and since CMUCL 20d, I had to change my ASDF configuration a couple of times. Apparently, I chose something that doesn't work on CMUCL. Anyway, it works now when supplying the full pathname.
> Pascal
> --
> Pascal Costanza
> The views expressed in this email are my own, and not those of my employer.

More information about the asdf-devel mailing list