[asdf-devel] Retest

Faré fahree at gmail.com
Tue Oct 15 02:20:41 UTC 2013

It's working reliably for me for Allegro (and modern) on Linux. Sigh.
Maybe sleep 1 is not reliable on these systems, and I need to sleep
for 2 seconds?
Nope, doesn't work for me.

I hate timing-dependent tests. Maybe I should make it time-independent
for ASDF using the cache frobbing like other tests, and only resort to
time-dependencies when testing native defsystems? But then, is it
still a fair comparison between defsystems?

I'm too tired to work on that anymore for tonight at least.
It's a new test, maybe it can be disabled for now,
at least for select OS/implementation combinations, with a
#+(or ...) (leave-test "Mysteriously fails on ... fixing later" ...)

—♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics• http://fare.tunes.org
To make an apple pie from scratch, you must first create the universe.
                — Carl Sagan

On Mon, Oct 14, 2013 at 10:08 PM, Robert P. Goldman <rpgoldman at sift.info> wrote:
> Faré wrote:
>> The ABCL test fails reliably on Linux, too, from the command-line.
>> But when I run it interactively at the REPL, it works reliably (!).
>> That's puzzling, to say the least, and would require more energy
>> than I have left at the moment.
>> Could we mark that as a known failure for ABCL for now?
> Hm.  Looks like Dave Cooper is having the same error on alisp on Windows.
> Is there any chance we have a problem where the make script is causing
> something odd to happen with the filesystem?

More information about the asdf-devel mailing list