[asdf-devel] pathname case issue ...

Chun Tian (binghe) binghe.lisp at gmail.com
Fri Jun 17 06:35:10 UTC 2011

Problem solved. My HFS filesystem seems going wrong, the directory node "/Users" was recognized by LispWorks as "/users". Today I mounted the disk into another Mac computer, manually created a new "/Users" directory and move previous sub-directories in, restart my laptop, and then everything goes fine now.

I remembered that several days ago, my Time Machine backup system suddenly decided to re-backup over 300GB data from my laptop, that must be the point when the "/Users" directory node change.  I don't know why this happen, but I solved it. Definitely not any issue in ASDF or LispWorks. Sorry for disturb.


在 2011-6-16,21:15, Faré 写道:

> On 16 June 2011 08:45, Robert Goldman <rpgoldman at sift.info> wrote:
>> On 6/15/11 Jun 15 -9:05 PM, Chun Tian (binghe) wrote:
>>> Hi, Faré
>>> It's caused by LispWorks' ASDF integration feature [1], it's also in attach. I have following line in my LispWorks init file:
>>> (example-compile-file "misc/asdf-integration.lisp" :load t)
>>> I didn't use it much, so I disabled it to make my life easier.  But it's also quite hard to determine which version of ASDF2 broke it.
>> There's nothing obvious in that asdf-integration file that should break
>> asdf's normal functioning.  They define a number of behaviors that
>> exploit ASDF data structures, but I don't see anything there that should
>> redefine existing behavior.  Of course, I may be overlooking something.
> Using either ASDF 2.014.6 or ASDF 2.016.2 on LispWorks Personal 6.0.1
> on Macintosh on a hfs volume, I cannot reproduce your issue.
> Is there something magic about the specific file you're seeing in the
> otherwise magic cl-net-snmp system you're using?
> [ François-René ÐVB Rideau | Reflection&Cybernethics | http://fare.tunes.org ]

More information about the asdf-devel mailing list