(require 'jna) failing in 1.3.2

Mark Evenson evenson at panix.com
Tue Jun 30 18:27:31 UTC 2015

> On 26 May 2015, at 08:39, Mark Evenson <evenson at panix.com> wrote:
>> On 25 May 2015, at 20:38, Scott L. Burson <Scott at sympoiesis.com> wrote:
>> Hi armed bears,
>> I'm getting a DependencyCollectionException from org.eclipse.aether.internal.impl.DefaultRepositorySystem: "failed to read artifact descriptor for net.java.dev.jna:jna:jar:4.1.0".  This is ABCL 1.3.2, JDK 1.8.0_40, on Linux.
>> ... I just tried JDK 1.7.0_71 and 1.6.0_25, and they both fail the same way.
>> Any ideas?
> I believe you are using a version of Maven that is currently incompatible with
> ABCL.  You may check the version of Maven that ABCL is using by inspecting the
> As noted in ticket [#390][], usage with Maven versions greater that 3.2.3 is
> not currently working.  Maven Aether doesn’t seem to have a stable API to code
> against or perhaps we just don’t understand it well enough, so even supposedly
> minor changes like from 3.2.3 to 3.2.5 break our usage.  We thought we had
> coded around the latest change to the Maven Aether contract, but it turns out
> post Maven 3.2.3, ABCL can only load Maven dependencies that have already been
> cached locally.
> [#390]: http://abcl.org/trac/ticket/390

With [r14788][], I think I have finally overcome the problems with post maven-3.2.3 and ABCL.

Pleas let me know if anyone finds this not to be the case.

[r14788]: http://abcl.org/trac/changeset/14788

More information about the armedbear-devel mailing list