loading lisp files from inside the java jar

Hamda Binte Ajmal hamda.binte.ajmal at gmail.com
Tue Aug 18 09:45:18 UTC 2015

I am sending this message again, as the last thread went a little too far.
I have developed a Java Application that runs lisp code at the back end,
and I use ABCL for that.
Before using the lisp commands, I load a few .lisp files so that I can call
the functions defined in those files.
Everything works fine as long as I run the application from Netbeans.
When I run the application from the jar file, it throws 'File not found
as the lisp files are not a part of file system inside the project jar.
I tried to follow the suggestions given by Mark
(load “jar:file:/absolute/path/to/file.jar!/path/within/jar/setup.lisp”)
It shows the same File not found error. Am i missing something here?
As suggested by Ralph to use (load-system-file "path/to/resource.lisp"), I
tried to use that, but I was unable to access sys package, please let me
know how to do this.

I find the help documentation and tutorials very confusing, and difficult
to understand.
Any hints will be appreciated.
Thanking in anticipation.
NUIG, Ireland.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/armedbear-devel/attachments/20150818/df1ef0c7/attachment.html>

More information about the armedbear-devel mailing list