[Armedbear-devel] controlling from where ASDF loads .abcl files

Robert Dodier robert.dodier at gmail.com
Wed Apr 23 21:16:37 UTC 2014

On 2014-04-23, Mark Evenson <evenson at panix.com> wrote:

>> After (require 'asdf) and (setf asdf:*central-registry*
>> '(*default-pathname-defaults*)) (which wasn't necessary before,
>> but that doesn't matter),
> I think it is a real bad idea to set *CENTRAL-REGISTRY* to a special, and I
> suspect this is the root of your problems.

It was suggested by a tutorial. Maybe it worked better for a previous
version of ASDF. I also tried setting it to an explicit path -- same
error as before (not finding the .abcl file that it successfully

> 2.  Create a file in this directory named “maxima.conf” containing the following form:
> 	(:tree (:home “tmp/maxima-5.33.0/“))

OK, when I do that, I get a complaint about "invalid source registry".
I gather that it needs to have an inheritance spec (I forget now why
that seems to be the case). Changed the file content to

  (:source-registry (:tree (:home “tmp/maxima-5.33.0/src/“)) :inherit-configuration)

and now the invalid source registry error has gone away but I still
get "component :MAXIMA not found". The maxima.asd is in that directory.

I guess there is an asdf-devel mailing list -- I'll try them now.
Sorry for the bother.


Robert Dodier

Armedbear-devel mailing list
Armedbear-devel at common-lisp.net

More information about the armedbear-devel mailing list