[armedbear-devel] cffi requires maven

Mark Evenson evenson at panix.com
Fri Nov 9 15:00:42 UTC 2012

On Nov 6, 2012, at 5:14 PM, Anton Vodonosov <avodonosov at yandex.ru> wrote:

> 12.10.2012, 17:31, "Anton Vodonosov" <avodonosov at yandex.ru>:
>> Tested revesion 14189 - works for me, maven is not
>> tried when JNA is in classpath.
> Something has changed since revision 14189 - maven is now
> tried even if JNA is in classpath.
> I am not sure, but probably happens before asdf:load-op,
> at the time of defsystem including component (:mvn "net.java.dev.jna/jna/3.5.1").

I substantially re-worked the logic in [r14236][], pushing the
resolution logic entirely into my method, instead of trying to
figure out the right dance with CLOS that ASDF performs to load
things.  The MVN component now takes a :CLASSNAME argument to specify
the class that indicates that the binary artifact has been loaded.

[r14236]: http://trac.common-lisp.net/armedbear/changeset/14236

"A screaming comes across the sky.  It has happened before but there is nothing to compare to it now."

More information about the armedbear-devel mailing list