[armedbear-devel] RfC: Renaming LispObject.writeToString() to LispObject.printObject()
ehuels at gmail.com
Thu Jul 14 22:07:11 UTC 2011
On Thu, Jul 14, 2011 at 8:51 PM, Ville Voutilainen <
ville.voutilainen at gmail.com> wrote:
> On 14 July 2011 21:42, Erik Huelsmann <ehuels at gmail.com> wrote:
> > Yesterday, we fixed #154 -- the PRINT-OBJECT regression in 0.26.0. Once
> > again, it turns out that our object printing and stringification routines
> > are confusingly named. Additionally, they are also under documented: The
> > writeToString() method calls toString(), but doesn't document the
> > between the two.
> > My idea would be to disambiguate the two functions by making
> > a java-side PRINT-OBJECT, renaming it to printObject() and documenting
> > that's what it does. Then, probably, the lisp side function
> > should be renamed to %print-object too. Probably, more adjustments are
> > required throughout the code base, but those are probably at the
> > 'implementation detail' level.
> > So, what's your take on it?
> By all means go for it. I've never quite understood why we have
> that calls toString(). Trying to find out from the codebase is
> non-trivial, and even
> our maintenance ends up making mistakes. Any clarification is a plus.
I have a commit sitting in my working copy to do just that (well, not the
%print-object part, actually). I'll wait a bit more for others to be able to
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the armedbear-devel