[armedbear-devel] Infinite loop loading compiled file

Erik Huelsmann ehuels at gmail.com
Tue Jan 25 21:11:44 UTC 2011

Hi Greg,

On Tue, Jan 25, 2011 at 10:01 PM, Greg Baryza <baryza at intersystems.com> wrote:
> I have a self-contained directory that has only the QI files needed to
> reproduce the problem.  In it there is a subdirectory called JAR where you
> should place the ABCL jar file of your choice.  _COMPILE.bat compiles files
> and then loads them; it hangs trying to load the fourth file. _BUILD.bat
> uses the same files but just loads the lisp sources; it works.

That looks like a manageable size reproduction. Interesting.

Could you send directly to me on my sender address? I'll check it out.



> I have all this in a 16KB zip file ready to go.  Where do you want it?
> <G>
> At 09:23 PM 1/25/2011, Erik Huelsmann wrote:
>> Hi Greg,
>> On Tue, Jan 25, 2011 at 3:33 PM, Greg Baryza <baryza at intersystems.com>
>> wrote:
>> > I recently became interested in the language QI. Â Since it did not run
>> > on
>> > ABCL (it does on SBCL, Allegro, LispWorks and others), I decided to see
>> > what it would take to move it there. Â From the QI mailing list, I found
>> > several others had tried on earlier versions of ABCL with inconclusive
>> > results. Â I decided to give it a try on 0.23.1.
>> >
>> > When I tried the standard script with compiles and then loads the
>> > compiled
>> > files, ABCL hangs it what appears to be an infinite loop try to load one
>> > of
>> > the compiled files. Â When I switch to just loading them in as Lisp
>> > sources,
>> > things seem to work (though some of the QI tests later fail).
>> >
>> > I tried the compile/load script under 0.24.0 today and the same hang
>> > happens.
>> >
>> > I have a small test case consisting only of the needed sources and a
>> > couple
>> > of .bat files for Windows that demonstrates the problem, but before I
>> > proceed further, has anyone seem anything like this. Â The file in
>> > question
>> > DEFUNs about 85 functions. Â Is that too many to provoke the "large
>> > file"
>> > problem I see mentioned here?
>> Could you provide us with a transcript for downloading/installing Qi
>> so we/I can test?
>> If this is the same old bug, the ball is really in Qi's park, but if
>> it's not, we're really happy to fix what we can!
>> Thanks!
>> Bye,
>> Erik.

More information about the armedbear-devel mailing list