[armedbear-devel] strange asdf behavior with 0.20.0

Kevin Raison raison at chatsubo.net
Wed Jun 9 18:20:48 UTC 2010

I just installed 0.20.0 and am now unable to load usocket, yet I can 
still load cl-ppcre and other Edi-ware.  Upon rolling back to 0.19.1, 
the same usocket package compiles and loads just fine.  I have tried 
using the binary distribution of 0.20.0 as well as building my own, with 
the same result.  There does not seem to be anything wrong with the 
usocket package definition itself.  Has anyone else seen this or know 
what is going on?  Here is the output of 0.20.0:

raison at mercury:~/.abcl/lib$ abcl
Armed Bear Common Lisp 0.20.0
Java 1.6.0_20 Sun Microsystems Inc.
Java HotSpot(TM) Server VM
Low-level initialization completed in 0.614 seconds.
Startup completed in 1.739 seconds.
Type ":help" for a list of available commands.
CL-USER(1): (asdf:oos 'asdf:load-op 'usocket)
; loading system definition from /home/raison/.abcl/systems/usocket.asd 
into #<PACKAGE "ASDF0">
Error loading /home/raison/.abcl/site/usocket-svn/usocket.asd at line 38 
(offset 1255)
#<THREAD "interpreter" {373E38}>: Debugger invoked on condition of type 
   Error while trying to load definition for system usocket from 
pathname /home/raison/.abcl/systems/usocket.asd: Unrecognized keyword 
argument :NAME
   0: TOP-LEVEL Return to top level.


More information about the armedbear-devel mailing list