[armedbear-devel] Serious bug involving UWP

Ville Voutilainen ville.voutilainen at gmail.com
Sun Oct 18 17:35:22 UTC 2009

2009/10/18 Erik Huelsmann <ehuels at gmail.com>:
> The ConditionThrowable should probably be named TransferOfControl
> instead, is what I'm now thinking. That would add to the
> "self-explanatory" level in the sources, I'd say.

For the superclass of GO/RETURN/etc. yes, but I don't think we should get rid
of ConditionThrowable. ConditionThrowable is actually not a good superclass for
GO/RETURN/etc., because I'd expect Java code to try and catch conditions, but
such catches should IMO not be mixed with catching GO/etc. To me it looks like
we need two superclasses, ConditionThrowable for conditions, TransferOfControl
for others.

More information about the armedbear-devel mailing list